Ruby on Rails 3.1 - 起動時に JavaScript Runtime エラー!

更新日時:


当方、Ruby on Rails 3.0 系から 3.1 系へ移行すべく、各種テストをしていた時のことです。

Rails アプリを production モードで起動させようとすると、以下のようなメッセージが出力されました。 ※development モードや test モードでは以下のようなメッセージは出力されません。

Error message:
    Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs
    for a list of available runtimes.
    (ExecJS::RuntimeUnavailable)

調査してみたところ、「Rails 3.1 execjs and Could not find a JavaScript runtime - Stack Overflow」によると node.js という JavaScript ランタイムが必要のようです。

http://nodejs.org/dist/ からソースを取得してインストールしてもよいのですが、Rails なので Gem パッケージで導入する方法と採ります。

Gemfile に以下の記述を追加して bundle install するだけです。

gem 'execjs'
gem 'therubyracer'

以上。

 

Sponsored Link

 

コメントする