mk-mode BLOG

このブログは自作の自宅サーバに構築した Debian GNU/Linux で運用しています。
PC・サーバ構築等の話題を中心に公開しております。(クローンサイト: GitHub Pages

ブログ開設日2009-01-05
サーバ連続稼働時間
Reading...
Page View 合計
Reading...
今日
Reading...
昨日
Reading...

WordPress - W3C(CSS)がSyntaxHighlighterでエラー!

[ ブログ ] [ CSS, W3C, WordPress, プラグイン ]

こんばんは。

先日あたりから、再チェックしてきた「W3C(XHTML1.0・CSS)」チェック。

うまくいっているように見えましたが、

記事内にソースコードを記載する際に「SyntaxHighlighter」というコードを綺麗に表示させるプラグインを使用すると、 このプラグインの「shCore.css」で「W3C(XHTML1.0・CSS)」チェックがエラーとなってしまいます。

WP_W3C_CSS_ERROR_1

そこで、以下のように対応しました。

  • 次のプロパティが正しくありません : min-height auto は min-height で利用できる値ではありません : auto auto → 「min-height:auto」はIE7用だが削除しても問題なかった。 → したがって削除。
  • プロパティ overflow-y は CSS レベル 2.1 に存在しませんが、[css3] に存在します : hidden hidden → 「CSS レベル 2.1」においては「overflow」はOKだが「overflow-y」はNGのようです。 → したがって削除。
  • 文法解析エラーが発生しました [,] → あってはならない箇所に「,」カンマが記述されている。 → したがって削除。

以下のブラウザで上記の修正が影響しないことを確認しました。

  • FireFox3.6.8
  • Opera10.61
  • IE6
  • IE7
  • IE8
  • GoogleChrome5.0

ここで1つ注意点。 ■今回の修正は一時的なものなので、「SyntaxHighlighter」をアップデート(バージョンアップ)した場合は再度チェックしてみる必要がある。 ということ。 (ま、投稿するたびにW3Cチェックしていれば、エラーに気付くはずですが・・・)

今日は以上です。

ではまた。

Comments